Archive for category TI-84+

TI loses again!

Well… It doesn’t seem like the 84+ Pocket.fr is even released in France yet, and the community has already managed to counter it. I’m not totally sure about what has happened, since most of the things are kept secret… But this time, someone (Brandon?) found an awesome exploit. It’s not just one of those “install third-party OS”-exploits (we’ve been able to write to flash on the Pocket.fr since the beginning) – it’s something that almost defies the laws of calcs…

The 84+ boot code has been written to.

Yeah.

Leave a comment

TI-84 Plus Pocket.fr

MoTI-84 Plus Pocket.frst of you who are in the calculator community already know about this… TI has released the TI-84 Plus Pocket.fr in France. It’s a new model that fits into a pocket, doesn’t have different hardware, and doesn’t have different software… At least that’s what’s what TI wants us to believe. In fact, they have changed the boot code, which is responsible for receiving the OS. It’s now at version 1.03, and the changes are horrible! As usual, no new features, but there is a nasty surprise. OSes that have been signed the normal way do not work anymore! This doesn’t just include all of the third-party OSes (I will miss you, WFRNGOS ;_;) but also every official OS, except for 2.55MP which has some kind of special signing. Thus, TI has killed support for nearly everything that matters! (Other than programming itself :P) The MathPrint OSes are horrible to use, and no real programmer or gamer would want to be stuck with one.

Of course, this doesn’t mean that TI has won. The 8x calculators are still under control of the community. The flash unlock exploits are still there, so we can write whatever we want to flash – the boot code only checks that things are OK at install, not at launch. Still, this is far worse that what TI has done before. I’m much more worried about the fact that they want to do this than the fact that third-party OSes can’t be installed the normal way now. TI is not only crippling the Nspire to ridiculous degrees – they’ve now started doing it with calculators that were once ours!

There’s also the question of why this was done. The answer is probably simple – TI wants to have control. They can’t accept that we install a third-party OS that does not have PTT or has CAS, etc. They also want to block things like our fake PTT screens and RAM clears, but they have not gotten any closer to that. But there’s something that’s strange – isn’t the reason for why TI wants this the standardized tests in America? The standardized tests that don’t even require you to clear RAM, and don’t require you to use a TI calculator with PTT either? (I could use Casio if I want to!) TI is doing more than what they should… And what really worries me is that even though TI wants this control in the US, the 84+ Pocket.fr is exclusive to France. What does this mean? The boot code has to be intended for more than just the Pocket.fr. This means that TI will start to force boot code 1.03 into EVERY SINGLE NEWLY PRODUCED 84+.

Screw TI. I like my Prizm.

Leave a comment